Webpage Access

Hi,

I downloaded RapidDeploy and unzipped it to a folder on my Windows 64-bit server. I then ran start-web-app.bat and it seemed to start ok. But I cannot access the webpage. I did notice a windows cmd wind flashed on the screen for about half a second and disappeared. There is nothing in the logs folder. Does anyone have any ideas?

Thanks,

Zack

 

Zack Wellin
Zack Wellin
7
| 3 1 1
Asked on 6/30/15, 12:39 PM
0
vote
981 Views

Hi Rob,

I think the following section taken from the "Getting Started Guide" might help:

JVM Heap Exhaustion causes the start script to fail silently on Windows

The RapidDeploy application sets the minimum heap size to 1024M. If your system cannot provide this level of heap, the start-web-app.bat script  may fail silently as the JVM crashes. Ensure you have enough heap, or  edit the start-web-app.bat script and amend  JAVA_OPTS as follows:

 e.g. change:

set "JAVA_OPTS=-Xms1024m -Xmx1024m -XX:MaxPermSize=512m -Drapiddeploy.properties=%MV_HOME%\bin\rapiddeploy.properties -D MV_HOME=%MV_HOME%"

to:

set "JAVA_OPTS=-Xms256m -Xmx1024m -XX:MaxPermSize=512m -Drapiddeploy.properties=%MV_HOME%\bin\rapiddeploy.properties -D MV_HOME=%MV_HOME%"

 

Regards

Richard

Administrator
Administrator
10245
| 1 0 0
Answered on 6/30/15, 1:12 PM
1
vote

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

Ask a Question

Keep Informed

About This Forum

This community is for professionals and enthusiasts of our products and services.

Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 6/30/15, 12:39 PM
Seen: 981 times
Last updated: 9/3/15, 3:47 PM